Auswahlmenü korrupt ...

#1 von geraldhu , 02.01.2010 23:59

Das neue Style gefällt mir sehr gut
jedoch braucht das Auswahlmenü (oben - unter den Grasbüscheln) wohl noch etwas Nachhilfe, da es nicht korrekt angezeigt wird. Außer ein paar Buchstaben und ein Fragezeichen ist nichts zu sehen (siehe Anhang).
Browser: Safari 4.0.4
Betriebsystem: Mac OSX 10.6.2

 
geraldhu
Besucher
Beiträge: 1.241
Registriert am: 08.09.2009


RE: Auswahlmenü korrupt ...

#2 von Weisser Schatten , 03.01.2010 00:12

das kann mit dem MAC zusammenhängen,
bei mir im Windows funktioniert es - habe vom browser keine ahnung

ian-jonathan der weiße schatten

 
Weisser Schatten
Besucher
Beiträge: 1.085
Registriert am: 11.07.2008


RE: Auswahlmenü korrupt ...

#3 von Alchemilla , 03.01.2010 00:36

Windows Vista mit Mozilla Firefox funktioniert. Vielleicht liegt es wie der Weisse Schatten schon schrieb an deinem PC? Hast du mal den Cache geleert und den Browser neu geoeffnet?

 
Alchemilla
Besucher
Beiträge: 1.129
Registriert am: 19.10.2008


RE: Auswahlmenü korrupt ...

#4 von geraldhu , 03.01.2010 03:02

Vielen Dank für die Empfehlungen. Diese hatte ich schon vor meiner Fragestellung abgecheckt, da ich um diese Problematik grundsätzlich Bescheid weiß, zumal ich mich mit Websiteprogrammierung schon eine Weile beschäftige.

Nun habe mir das ganze mal mit verschiedenen Browser (PC und Mac) angesehen - mit dem Ergebnis, daß neben dem Safari auch Googles Chrome (am Mac) die von mir Eingangs angesprochenen Darstellungsfehler produziert.

Darüber hinaus habe ich mir erlaubt den Seitenquelltext genauer unter die Lupe zu nehmen. Dabei sind mehrere Ungereimtheiten aufgetaucht (siehe: http://jigsaw.w3.org/css-validator/valid...y.siteboard.org). Ob diese dazu beitragen, daß es zu den Darstellungsfehlern kommt müßte man sich im Detail näher ansehen ...

 
geraldhu
Besucher
Beiträge: 1.241
Registriert am: 08.09.2009


RE: Auswahlmenü korrupt ...

#5 von Roidsear , 03.01.2010 12:17

Also hier (Safari 4.0.4 MacOS 10.5.8) sieht alles prima aus.

@geraldhu:
Die CSS-Fehler sollten soweit ich das sehe allerdings nicht für Deine Anzeigefehler verantwortlich sein.. ich kann mir das aber gerne nochmal näher ansehen, wenn ich nächste Woche wieder im Büro bin.
Daß Chrome ähnliches anzeigt, ist relativ logisch - der benutzt ja die gleiche Darstellungs-Engine wie Safari (Webkit), und das lässt theoretisch wirklich auf einen Fehler im CSS etc. schließen. Seltsam nur, daß weder Chrome für Win, Chrome für Mac noch Safari bei mir Probleme gemacht haben. Der einzige Unterschied zwischen Deinem und meinem System ist ja nur die Version vom MacOS... das sollte "theoretisch" ja nicht ins Gewicht fallen..

 
Roidsear
Besucher
Beiträge: 185
Registriert am: 08.12.2009


RE: Auswahlmenü korrupt ...

#6 von geraldhu , 03.01.2010 15:02

Zitat von Roidsear
Also hier (Safari 4.0.4 MacOS 10.5.8) sieht alles prima aus.

@geraldhu:
Die CSS-Fehler sollten soweit ich das sehe allerdings nicht für Deine Anzeigefehler verantwortlich sein.. ich kann mir das aber gerne nochmal näher ansehen, wenn ich nächste Woche wieder im Büro bin.
Daß Chrome ähnliches anzeigt, ist relativ logisch - der benutzt ja die gleiche Darstellungs-Engine wie Safari (Webkit), und das lässt theoretisch wirklich auf einen Fehler im CSS etc. schließen. Seltsam nur, daß weder Chrome für Win, Chrome für Mac noch Safari bei mir Probleme gemacht haben. Der einzige Unterschied zwischen Deinem und meinem System ist ja nur die Version vom MacOS... das sollte "theoretisch" ja nicht ins Gewicht fallen..



Vielen Dank für Deine Antwort.

Hab mir mal die Seite mit meinem PowerBook G4 (OSX 10.4.11) angesehen, da gab es keine Probleme - scheint also am Webkit in 10.6.2 zu liegen.
und/oder
Möglicherweise schaltet Safari und Chrome in den Quirks-Modus um - begründet durch den nicht W3C-konformen CSS-Code, welcher bei der Doctype "XHTML 1.0 Strict" wohl nicht mehr toleriert wird - was in dann zu der Fehlinterpretation in der Darstellung führt ...

 
geraldhu
Besucher
Beiträge: 1.241
Registriert am: 08.09.2009


RE: Auswahlmenü korrupt ...

#7 von Inge , 03.01.2010 16:25



LG Inge

 
Inge
Besucher
Beiträge: 5.127
Registriert am: 28.09.2008


RE: Auswahlmenü korrupt ...

#8 von Alchemilla , 03.01.2010 16:51

Ja genau Inge, ich weiss absolut was du meinst... . Boehmische Doerfer fuer meinereiner, aber die Herren werden schon wissen wie sie das Problem beheben.. hoffe ich!

 
Alchemilla
Besucher
Beiträge: 1.129
Registriert am: 19.10.2008


RE: Auswahlmenü korrupt ...

#9 von Lugsciath , 03.01.2010 18:37

Eventuell liegt es am Cache - sowohl Forenseits, als auch Browserabhängig.

Bitte also im ACP bei phpbb den Cache (Allgemein) löschen, aber auch und grade die Styles im ACP (Styles) -> Templates, Themes usw. aktualisieren. Bei mir funzt es unter FF und XP ... evtl auch mal im phpbb Forum nachfragen.

Soweit meine 5 ct

 
Lugsciath
Besucher
Beiträge: 27
Registriert am: 05.07.2009


RE: Auswahlmenü korrupt ...

#10 von angelikaherchenbach , 03.01.2010 20:47

Ich muss mich jetzt mal völlig inkompetent einmischen:

FASZINIEREND, mit was für Begriffen und Kenntnissen Ihr da um Euch werft!

Ab und zu verstehe ich sogar ein Wort, z.B. "Mac".
Das läßt mich hoffen, irgendwann auch mal Antworten auf Fragen zu kriegen - denn ich bin wie die Jungfrau zum Kinde zu einem Mac gekommen und blicke es oft nicht.


Angelika

angelikaherchenbach  
angelikaherchenbach
Besucher
Beiträge: 3.560
Registriert am: 04.01.2009


RE: Auswahlmenü korrupt ...

#11 von Roidsear , 04.01.2010 07:07

Das mit dem Cache im ACP löschen ist ne gute Idee...
(ACP = das Kontrollzentrum des Forums für den Administrator, Cache = Zwischenspeicher, um Forumsinhalte schneller darstellen zu können. Wenn man viel am Forum verändert, ist mitunter schonmal quasi Quark im Zwischenspeicher, was zu lustigen Darstellungsfehlern führen kann.)

So weit wie ich das sehe, rendert zumindest Chrome nicht wie im Doctype gewünscht im XHTML-Strict Modus, sondern tatsächlich im Quirks Mode. Vielleicht könnte man mal versuchen den Doctype auf Transitional zu stellen, dann dürften auch die CSS-Fehler durchgehen...
(Doctype = quasi die Regeln, wie die Angaben im Quelltext der Seite interpretiert werden sollen - steht der doctype auf "Strict", sollte man sich penibel an die Regeln halten, wenn er auf "Transitional" steht, kann man schonmal ne "3" grade sein lassen, grob gesagt..)

Ich hoffe, der Beitrag ist zumindest im Groben auch für "Nicht-Fachidioten" verständlich...

Allen einen guten Morgen und einen entspannten Start in die Woche!

 
Roidsear
Besucher
Beiträge: 185
Registriert am: 08.12.2009


RE: Auswahlmenü korrupt ...

#12 von Weisser Schatten , 04.01.2010 14:28

hast dir große mühe gegeben, aber ich sehe nur weiße schatten -
aber es betrifft mich ja (den göttern sei dank) nicht

ein neues jahr - auch neue herausforderungen
so ist es halt

ian-jonathan aus dem verschneiten winterwald wo der frost in den bäumen knallt

 
Weisser Schatten
Besucher
Beiträge: 1.085
Registriert am: 11.07.2008


   


Xobor Einfach ein eigenes Forum erstellen | ©Xobor.de
Datenschutz